Enforce user to update the newly deployed ClickOnce release

Filed in ClickOnce Leave a comment

Problem:

There are some time where you would like the user to forcely update the release which is deployed via ClickOnce.

Solution:

Right Click Project > Properties > Publish Tab > Click Updates… buttons > Check the option (Specify a minimum required version for this application) to the latest version. With this option when user open the application it will automatically update the specified version.

Unable to install or run application. The application requires that assembly Microsoft.Practices.EnterpriseLibrary.Data Version 3.1.0.0 to be installed in Golbal Assembly Cache (GAC) first. ClickOnce

Filed in ClickOnce Comments Off

Problem:

Unable to install or run application. The application requires that assembly Microsoft.Practices.EnterpriseLibrary.Data Version 3.1.0.0 to be installed in Golbal Assembly Cache (GAC) first. ClickOnce

Solution:

Right Click Project > Properties > Publish Tab > Click Application Files… buttons > Set the Publish Status of problem dlls to (Include) or (Include Auto) whatever is available.

TOP